Unity-SDK Version Compatibility

This reference describes the relationship between Unity versions, Oculus PC and Mobile SDKs, and Oculus Unity Integration and Utilities packages.

We currently support the 5.4, 5.5, and 5.6 branches of the Unity editor. Our Utilities package no longer supports Unity versions prior to 5.3.4p5.

The Oculus integration includes preliminary support for Unity 2017 Beta. If you have any problems or questions, please let us know in our Unity Developer Forum.

The following chart describes which Oculus SDKs are included in each OVRPlugin version, and which Oculus SDKs they utilize. Any Unity version may be updated to a later version of Oculus support by importing the Utilities package. OVRPlugin is released first with Utilities for Unity, and is typically bundled in the next Unity Editor version one to three weeks later. For more information, see OVRPlugin.

Release DateUtilities VersionOVRPlugin VersionPC SDK Mobile SDKMin. Required Unity Version
6/29/20171.16.0-beta1.16.01.16.01.6.05.4.3p4 or later, 5.5.x, 5.6.x
6/3/20171.15.01.14.11.15.01.5.05.4.3p4 or later, 5.5.x, 5.6.x
5/2/20171.14.01.14.01.14.01.5.05.4.3p4 or later, 5.5.x, 5.6.x

Legacy Compatibility

This section describes Oculus SDK and Integration compatibility with Unity Editor versions prior to the Oculus 1.14.0 release, when we began shipping OVRPlugin in the Utilities for Unity package.

Utilities for Unity 5.x Versions

Release DateOVRPlugin / UtilitiesPC SDK Mobile SDKUnity
4/8/20171.13.01.13.11.5.05.6.0p3 or later
4/25/20171.13.01.13.11.5.05.5.3p2 or later
4/27/20171.12.01.12.01.0.4.55.4.5p1 or later
3/30/20171.13.01.12.01.0.4.55.6.0f3 or later
3/30/20171.13.01.12.01.0.4.55.5.2p3 or later
3/30/20171.13.01.12.01.0.4.55.4.5f1 or later
3/10/20171.12.01.12.01.0.4.55.5.2p3 or later
3/10/20171.12.01.12.01.0.4.55.4.5f1 or later
3/10/20171.12.01.12.01.0.4.55.3.8f1 or later (deprecated)
2/1/20171.11.01.11.01.0.4.55.5.1p2 or later
2/8/20171.11.01.11.01.0.4.55.4.4p3 or later
2/1/20171.11.01.11.01.0.4.55.3.7p4 or later (deprecated)
11/28/20161.10.01.10.01.0.45.5.0p1 or later
11/28/20161.10.01.10.01.0.45.4.3p3 or later
11/28/20161.10.01.10.01.0.45.3.7p2 or later
11/1/20161.9.01.9.01.0.45.4.2p2 or later
11/1/20161.9.01.9.01.0.45.3.6p8 or later
9/15/20161.8.01.8.01.0.35.4.1p1 or later
9/15/20161.8.01.8.01.0.35.3.6p5 or later
8/18/20161.7.01.7.01.0.35.4.0p3 or later
8/18/20161.7.01.7.01.0.35.3.6p3 or later
7/28/20161.6.01.5.01.0.35.4.0b16 or later
7/28/20161.6.01.6.01.0.35.3.6p1 or later
6/30/20161.5.01.5.01.0.35.4.0b16 and later
6/30/20161.5.01.5.01.0.35.3.4p5 and later
4/20/20161.3.21.3.21.0.0.15.4.0b11 and later
4/20/20161.3.21.3.21.0.0.15.3.3p3 and later
3/28/20161.3.01.3.01.0.0.15.3.4p1
10/30/20150.1.3.0 Beta0.8.0.0 0.6.2.05.2.2p2
10/1/20150.1.2.0 Beta0.7.0.00.6.2.05.2.1p2
7/6/20150.1.0.0 Beta0.6.0.10.5.05.1.1

Unity 4.x Integration Versions

Release DateIntegrationPC SDK Mobile SDKUnity
3/28/20161.3.01.3.01.0.0.14.7.0f1
10/30/20150.8.0.00.8.0.01.0.04.6.9p1
9/08/20150.6.2.00.7.0.00.6.2.04.6.7+
8/14/20150.6.1.00.6.0.10.6.1.04.6.7+
8/7/20150.6.0.20.6.0.10.6.0.14.6.7
6/25/2015D 0.6.0.10.5.0.10.6.0.14.6
6/12/2015M 0.6.0.10.5.0.10.6.0.14.6
5/15/2015D 0.6.0.00.5.0.10.5.04.6
3/31/2015M 0.5.00.5.0.10.5.04.6
3/26/2015D 0.5.0.10.5.0.10.5.04.6
3/20/2015M 0.4.3.10.4.40.4.3.14.5
2/27/2015M 0.4.30.4.40.4.34.5
1/23/2015M 0.4.20.3.20.4.24.5
1/7/2015M 0.4.10.3.20.4.14.4
12/4/2014D 0.4.40.4.40.4.04.6
11/12/2014M 0.4.00.3.20.4.04.4
11/10/2014D 0.4.3.10.4.3.1N/A4.5
10/24/2014D 0.4.30.4.3N/A4.5
9/4/2014D 0.4.20.4.2N/A4.5
8/11/2014D 0.4.10.4.1N/A4.4
7/24/2014D 0.4.00.4.0N/A4.4
5/22/2014D 0.3.20.3.2N/A4.3
4/14/2014D 0.3.10.3.1N/A4.3
10/10/2013D 0.2.50.2.5N/A4.3